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Using This Book

This section describes the contents of this guide and the typographical conventions it uses.

About this book vii

How this book is organized vii

Typographical conventions vii
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About this book ▲ Using This Book
About this book

This book describes how to use NetSyncPLUS to manage DATUM network elements. It is 
intended for operators responsible for managing, maintaining, and monitoring 
telecommunications networks. 

How this book is organized

This book is organized as follows: 

• Chapter 1, Introduction, provides an overview of NetSyncPLUS.

• Chapter 2, Network Scenarios, describes how to perform common tasks using 
NetSyncPLUS.

• Chapter 3, Fault Management, describes the module that you use for day-to-day 
monitoring of the network elements in your network.

• Chapter 4, Configuration Management, describes the module that you use to add, 
modify, or delete network elements in your network.

• Chapter 5, Performance Management, describes the performance management 
module.

• Chapter 6, Security Management, describes the module that you use to add, modify, or 
delete users of NetSyncPLUS.

• Chapter 7, System Administration, describes the module that you use to create filters 
that specify what information to include on the NetSyncPLUS displays.

• Appendix A, Backups and Restores, describes how to perform backups and restores of 
your data.

This book also contains an Index.

Typographical conventions

Source code, screen displays, filenames, and directory names. These are shown in boldface 
Courier. For example:
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Typographical conventions ▲ Using This Book
The file my_file.c is located in /my_path/my_directory.

Optional text and variables. Text that you can optionally enter is enclosed in square brackets. 
Variables that you replace with actual values are shown in italic boldface courier. For example:

To make a copy of the file, enter:

cp [-ip] filename1 filename2

cp is the command that you enter. filename1 and filename2 are mandatory 
user-supplied arguments that you replace with the actual names of the desired source 
and destination files. -i and -p are optional arguments.

User input, optional user input, and user-supplied variables. User input (text that you type) 
is shown in italic, boldface Courier.

Keyboard combinations. Keys that you press together are shown with a plus sign between 
them. For example:

Press CTRL+E, then ALT+F4.

Filename nomenclature. When a filename is mentioned, the full pathname is usually omitted. 
You should provide the required pathname.

Command line nomenclature. This manual assumes that you press RETURN after you enter 
a command, and that a command fits on a single line. When a command line extends beyond 
one line in this manual, it is shown with a backslash (\) at the end of the line to indicate that 
the command continues. You should not press RETURN until you have entered the entire 
command.

☞ Important. The Important notation is used to highlight information from the preceding text. 
It may be used to point out something notable that was not stated explicitly or to make 
recommendations for specific circumstances, for example.

M Caution. The Caution notation is used to warn readers of possible system failure, loss of 
data or damage to network elements.
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1 Introduction

This chapter provides an overview of NetSyncPLUS.

1.1 Overview 1-3

1.1.1 Regions and sites 1-3

1.1.2 NE identification 1-4

1.2 Starting NetSyncPLUS 1-4

1.3 Product navigational aids 1-6
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Overview ▲ 1 Introduction
1.1 Overview

NetSyncPLUS provides an easy-to-use interface for managing network elements (NEs). The 
network elements that NetSyncPLUS manages are the PRR10, PRS-50, and TSG3800 .

1.1.1 Regions and sites

NetSyncPLUS uses the concepts of regions and sites to group NEs. Regions and sites are 
mainly containers. 

• Region: contains one or more sites. The only other attribute of a region is its 
geographical location.

• Site: contains one or more NEs. Other attributes of a site include the name and 
telephone number of the site manager, the site’s street address, and its geographic 
location.

Figure 1.1 illustrates this the relationship between regions, sites, and NEs:

Figure 1.1 Regions, sites, and NEs

NetSyncPLUS has two defaults that enable you to enter your network information in a 
bottom-up, as well as a top-down, manner:

When you add an NE or create a site, you can initially create it under one of these defaults. 
Then, you can later assign it to the site or region to which it actually belongs.

UnassignedEquipment The default site. 

UnassignedSites The default region. 

Region

Site Site

NE NE

NE

NE NE
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1.1.2 NE identification

Each network element has the following attributes that identify it to NetSyncPLUS:

The combination of the IP address and the port number uniquely identify the NE. 
However, when you select an NE in the NetSyncPLUS dialog boxes, you select it using its 
name. For this reason, you want to be sure to assign a descriptive name to the NE. 

1.2 Starting NetSyncPLUS 

When you log in to the operating system, the NetSyncPLUS login dialog box, a clock, and a 
console icon are displayed. You use the login dialog box, illustrated in Figure 1.2, to log in to 
NetSyncPLUS.

Figure 1.2 Login dialog box

name The name assigned to the network element. When a network element is initially 
installed, it has a factory-assigned name, which is the same for all NEs of a 
particular NE type. 

You can assign a unique, descriptive name to an NE, either directly using the 
craftperson interface for the device or using NetSyncPLUS. For information on 
using NetSyncPLUS to assign a name, see page 4-11.

IP address The network address of the NE’s terminal server. Equivalent to host name.

Port number The port number used by the NE’s terminal server. Equivalent to service name.
1-4 NetSyncPLUS User Guide ▲ October 1998



Starting NetSyncPLUS ▲ 1 Introduction
Using the console icon, illustrated in Figure 1.3, you can open the console window and view 
diagnostic messages pertaining to the NetSyncPLUS software. This console window has no 
function in the management of your network or NEs. You cannot type anything in the console 
window.

Figure 1.3 Console icon

When you log in to the NetSyncPLUS product, the tool bar shown in Figure 1.4 is displayed.

Figure 1.4 NetSyncPLUS tool bar

You use this tool bar to access the NetSyncPLUS functions. The following table describes 
each of these functions:

map

physical
equipment

alarm
list

event
list

software
management

configuration
management

inventory
list
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Product navigational aids ▲ 1 Introduction
1.3 Product navigational aids

This section provides two navigational aids to help you find your way around the 
NetSyncPLUS graphical user interface (GUI).

• Table 1.1 lists tasks and the paths through the GUI and shows you how to reach the 
appropriate dialog box to perform a particular task.

• Figures 1.5 through 1.7 provide a map of the GUI that shows you how the menus and 
dialog boxes are organized to help you locate a specific dialog box.

Fault Management Use this function to perform fault management for your network. 
This function is represented by four buttons on the tool bar, which 
enable you to view the following information:

• a map display to monitor your network

• a physical equipment display that provides details about 
specific physical network element

• an alarm list that lists alarms

• an event list that lists events

Configuration Management Use this function to manage the configuration of NEs on your 
network. This function is represented by three buttons on the tool 
bar, which enable you to:

• download firmware to the equipment

• add, modify, or delete NEs on your network

• print reports about the NEs on your network

Performance Management Use this function to view and print performance monitoring graphs 
for the NEs on your network.

Security Management Use this function to add, modify, or delete users of the 
NetSyncPLUS product.

System Administration Use this function to create filters that specify the information you 
want to see on the map display and alarm list.

Online Help Use this function to view online product documentation.
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Product navigational aids ▲ 1 Introduction
These two navigational aids are meant to be used together. You can look up the task you 
want to perform in the table and then trace the path of dialog boxes and menus using the 
map.

☞ Important. The GUI provides keyboard shortcuts to speed your navigation through the 
menus. For each menu and menu item, the shortcut is underlined.

Table 1.1 lists some of the tasks that you might want to perform and describes the path to reach 
the appropriate dialog box. All paths begin with one of the buttons on the tool bar.
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Table 1.1 Tasks and paths

Task/Dialog Box Path through the GUI

Alarms

Acknowledge alarms/alarm list alarm list->Action Menu->Acknowledge Selected 
Alarms

Clear alarms/alarm list alarm list->Action Menu->Clear Selected Alarms

View alarm details/alarm list alarm list->Action Menu->Alarm Detail Display

Change the alarm list format/alarm list alarm list->Configure Menu->Add Column, Delete 
Column, and Move Column

Change the alarm list sorting/alarm list alarm list->File Menu->Sort->By Time or By Severity

Save or print the alarm list/alamr list alarm list->File Menu->Export

Configure the alarm log/alarm list alarm list->Configure Menu->Alarm Log

Events

View event details/event list event list->Action Menu->Event Detail Display

Change the event list format/event list event list->Configure Menu->Add Column, Delete 
Column, and Move Column

Save or print the event list/event list event list->File Menu->Export

Configure the event log/event list event list->Configure Menu->Event Log

Filtering

Change the filter for the map display/Use Filter map display->File Menu->Use Filter

Change the filter for the Alarm List/Use Filter alarm list->File Menu->Use Filter

Change the filter for the alarm log/Use Filter alarm list->Configure Menu->Alarm Log->Use Filter

Create a filter/Alarm Filter Manager System Administration

Changing an existing filter/Alarm Filter 
Manager

System Administration
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Product navigational aids ▲ 1 Introduction
Network Elements

Add an NE/Add a Network Element Configuration Management->Add

Modify an NE’s routing information (such as IP 
address, port, and so on)/Modify Network 
Element

Configuration Management->Modify->Modify 
Equipment->Modify Network Element->Routing 
Information button

Delete an NE Configuration Management->Delete->Delete 
Equipment

View an NEs status/physical equipment display physical equipment display->Open Equipment

Communicate directly with an NE/TL1 Session alarm list->Tools Menu->TL1

Network Element Cards

Configure input cards/Input Configuration Configuration Management->Modify->Modify 
Equipment->Input Card # button

Configure input ports/Input Ports Configuration Management->Modify->Modify 
Equipment->Input Port # button

Configure input port thresholds/Threshold 
Configuration

Configuration Management->Modify->Modify 
Equipment->Input Port # button->Edit Menu->Thresholds

Configure input reference ports/Reference 
port

Configuration Management->Modify->Modify 
Equipment ->Input Card # button->Edit 
Menu->Reference Port

Configure CPU card/CPU Card Configuration Configuration Management->Modify->Modify 
Equipment->CPU button

Configure clock card/Clock Card 
Configuration

Configuration Management->Modify->Modify 
Equipment->Clock button

Configure reference clock/Reference CLK./FG Configuration Management->Modify->Modify 
Equipment->Reference button

Configure frame generator/Frame Card 
Configuration

Configuration Management->Modify->Modify 
Equipment->Frame Generator button

Configure reference frame 
generator/Reference CLK./FG

Configuration Management->Modify->Modify 
Equipment->Reference button

Configure controller card Configuration Management->Modify->Modify 
Equipment->Controller A or Controller B button

Table 1.1 Tasks and paths

Task/Dialog Box Path through the GUI
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Configure output card/Output Configuration Configuration Management->Modify->Modify 
Equipment->Output Card button

Configure alarm severities Configuration Management->Modify->Modify 
Equipment ->CTL-A Alarm Severities or CTL-B Alarm 
Severities button

Performance Graphing

Create performance graph Performance Management

Printing

Print the map display/map display map display->File Menu->Print

Print the physical equipment display/physical 
equipment display

physical equipment display->File Menu->Print

Print the alarm list/alarm list alarm list->File Menu->Export

Print the event list/event list event list->File Menu->Export

Program Users

Add users/Security Manager Security Management->Edit Menu->Add User

Modify users/Security Manager Security Management->Edit Menu->Modify User

Delete users Security Management->Edit Menu->Delete User

Regions

Add a region/Region Editor map display->Configure Menu->Region->Add Region

Modify a region/Region Editor map display->Configure Menu->Region->Modify 
Region

Delete a region map display->Configure Menu->Region->Delete 
Region

Sites

Add a site/Site Details map display->Configure Menu->Site->Add Site

Modify a site/Site Details map display->Configure Menu->Site->Modify Site

Delete a site map display->Configure Menu->Site->Delete Site

View site details/Site Details map display->File Menu->Show Detail

Table 1.1 Tasks and paths

Task/Dialog Box Path through the GUI
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2 Network Scenarios

This chapter describes some common network scenarios using NetSyncPLUS.

2.1 Overview 2-3

2.2 Setting up your network 2-3

2.3 Reconfiguring your network 2-6

2.3.1 Moving regions, sites, and NEs 2-6

2.3.2 Deleting regions, sites, or NEs 2-7

2.3.3 Changing NE configuration parameters 2-7

2.4 Monitoring your network 2-8

2.4.1 Using the map display 2-8

2.4.2 Using the alarm list 2-9

2.4.3 Using the event list 2-11

2.5 Monitoring performance 2-12
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Overview ▲ 2 Network Scenarios
2.1 Overview

This chapter describes some common scenarios using NetSyncPLUS. The scenarios in this 
chapter refer to later chapters in this book which describe in detail how to use the 
NetSyncPLUS graphical user interface (GUI).

This chapter includes the following types of scenarios:

• Setting up your network

• Reconfiguring your network

• Monitoring your network for alarms

2.2 Setting up your network

To set up your network, you need to add the regions, sites, and network elements it contains. 
You can add regions, sites, and network elements in any order. This section describes how to 
set up your network in both a top-down and a bottom-up manner.

To set up your network top-down:

1. Add a region.

From the map display, select Region from the Configuration menu. Then, select Add 
Region from the cascade menu.

On the Region Editor dialog box, specify the geographic coordinates for your 
region’s location. Then, save your region. For more information on adding a 
region, see page 3-7.

2. Add a site.

From the map display, select Site from the Configuration menu. Then, select Add Site 
from the cascade menu.

On the Site Details dialog box, specify the region to which this site belongs. Enter a site 
name and the geographic coordinates for site’s location. Then, save your site. For more 
information on adding a site, see page 3-10.
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3. Add a network element.

You use the configuration management function to add network elements. Select Add 
from the Configuration Management tool bar. 

On the Add Network Element dialog box, specify the site to which this NE belongs. 
Complete all the other fields on this dialog box as described on page 4-9.

☞ Important. When a network element is initially installed, it has a factory-assigned 
name, which is the same for all NEs of a particular NE type. You can assign a unique, 
descriptive name to an NE, either directly using the craftperson interface for the device 
or by entering it on the Add Network Element dialog box. Since you use the NE’s 
name to select it in NetSyncPLUS dialog boxes, you want to be sure to assign a 
descriptive name to the NE.

4. Enter any configuration and inventory information for the NE.

Select Modify from the Configuration Management tool bar. On the Modify Network 
Element dialog box, click any of the buttons to enter configuration and inventory 
information for the cards that this NE contains.

For more information on modifying an NE, see page 4-11.
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To set up your network bottom-up:

1. Add a network element.

You use the configuration management function to add network elements. Select Add 
from the Configuration Management tool bar. 

On the Add Network Element dialog box, use the default (UnassignedEquipment) as 
the site to which the NE belongs and complete all other fields (see page 4-9).

☞ Important. When a network element is initially installed, it has a factory-assigned 
name, which is the same for all NEs of a particular NE type. You can assign a unique, 
descriptive name to an NE, either directly using the craftperson interface for the device 
or by entering it on the Add Network Element dialog box. Since you use the NE’s 
name to select it in NetSyncPLUS dialog boxes, you want to be sure to assign a 
descriptive name to the NE.

2. Enter any configuration and inventory information for the NE.

Select Modify from the Configuration Management tool bar. On the Modify Network 
Element dialog box, click any of the buttons to enter configuration and inventory 
information for the cards that this NE contains.

For more information on modifying an NE, see page 4-11.

3. Add a site.

From the map display, select Site from the Configuration menu. Then, select Add Site 
from the cascade menu.

On the Site Details dialog box, use the default (UnassignedSites) as the region to which 
this site belongs. Enter a site name and the geographic coordinates for site’s location. In 
the Network Elements group box on the Site Details dialog box, click the Add button to 
add network element to the site. Then, save your site. For more information on adding 
a site, see page 3-10.
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4. Add a region.

From the map display, select Region from the Configuration menu. Then, select Add 
Region from the cascade menu.

On the Region Editor dialog box, specify the geographic coordinates for your region’s 
location. Use the two list boxes at the bottom of the Region Editor dialog box to 
add sites to your region. Then, save your region. For more information on adding 
a region, see page 3-7.

2.3 Reconfiguring your network

This section provides information on the following tasks:

• It describes how to move NEs from one site to another and how to move sites from one 
region to another. 

• It provides pointers to information on how to delete regions, sites, and NEs from your 
network.

• It describes how to change configuration parameters for NEs

2.3.1 Moving regions, sites, and NEs

To move an NE:

1. Modify the site to which you want to move the NE.

From the map display, select Site from the Configuration menu. Select Modify Site from 
the cascade menu, and select the site from the Modify Site dialog box.

2. In the Network Elements group box on the Site Details dialog box, click the Add button 
to add network element to the site. 

When you add the NE to this site, it is automatically removed from the site to which it 
was previously assigned.

3. Save the site.

For more information on modifying a site, see page 3-12.
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To move a site:

1. Modify the region to which you want to move the site.

From the map display, select Region from the Configuration menu. Select Modify 
Region from the cascade menu, and select the region from the Modify Region dialog 
box.

2. Use the two list boxes at the bottom of the Region Editor dialog box to add the site to 
this region. 

When you add the site to this region, it is automatically removed from the region to 
which it was previously assigned.

3. Save the region.

For more information on modifying a region, see page 3-8.

2.3.2 Deleting regions, sites, or NEs

• For information on deleting a region, see page 3-9.

• For information on deleting a site, see page 3-12.

• For information on deleting an NE, see page 4-14.

2.3.3 Changing NE configuration parameters

There are several ways to access a dialog box where you can change NE configuration 
parameters. The two most obvious ways to change an NE’s configuration are using 
configuration management (see page 4-11) or the physical equipment display (see page 3-13). 
However, you can also easily change an NE’s configuration from the map display or alarm list 
as described below.

If a site contains a single NE, you can change its configuration parameters as described below: 

1. On the map display, double-click the region containing the NE.

The map display zooms in to display the sites in that region.

2. Click a particular site to select it.
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3. Click the physical equipment display quick-access button.

4. On the graphical representation of the NE, double-click a card to view the configuration 
parameters set for that card.

5. Make any changes and save the configuration.

For more information about the map display, see page 3-4. For more information on 
using the physical equipment display, see page 3-13.

To change NE configuration from the alarm list:

1. Select an alarm reported by the NE whose configuration parameters you want to 
change.

2. Click the physical equipment display quick-access button.

3. On the graphical representation of the NE, double-click a card to view the configuration 
parameters set for that card.

4. Make any changes and save the configuration.

For more information on using the alarm list, see page 3-16. For more information on 
using the physical equipment display, see page 3-13.

2.4 Monitoring your network

In the day-to-day operation of your network, you will probably use the map display, alarm 
list, and event list most often to monitor your network. Each of these displays provides a 
different view of network activity. This section provides some tips on how to use these 
displays to monitor alarms and events. 

2.4.1 Using the map display

The map display provides a geographical map display of your network. Typically, regions 
appear as green boxes on the map display. If a region contains a NE with an alarm, the color 
of the region changes to indicate the severity of the alarm. For more information about the 
map display, see page 3-4.
2-8 NetSyncPLUS User Guide ▲ October 1998



Monitoring your network ▲ 2 Network Scenarios
You can customize the regions and alarms that the map display indicates by applying a filter 
to the display. To apply a filter, select Use Filter from the File menu. For information on 
creating filters, see page 7-4.

To zoom in on a particular region and site to view more information about an alarm:

1. Double-click the region on the map display.

The map display zooms in to display the sites in that region.

2. Click a particular site to select it.

Once you have selected a site, you can view detailed information about that site.

3. If the selected site contains a single NE, you can click the physical equipment display 
quick-access button to view a graphical representation of the NE.

On the graphical representation of the NE, you can double-click any card to view or 
change information about that card. For more information on using the physical 
equipment display, see page 3-13.

4. To view details about the alarm and acknowledge or clear it, click the alarm list 
quick-access button.

For more information on using the alarm list to view alarm details, acknowledge 
alarms, or clear alarms, see page 3-16.

2.4.2 Using the alarm list

The alarm list lists the alarms that have been reported. The alarms are color-coded according 
to severity. For more information on using the alarm list, see page 3-16.

You can customize the alarms that the alarm list lists by applying a filter. To apply a filter, 
select Use Filter from the File menu. For information on creating filters, see page 7-4.

To view details about an alarm:

1. Select the alarm from the alarm list.

2. Select Alarm Detail Display from the Action menu.
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To view information about the region and site the alarm occurred:

1. Click the map display quick-access button.

The map display shows the region in which the alarm occurred.

2. Double-click the region.

The map display zooms in to display the sites in that region.

3. Click a particular site to select it.

For more information about the map display, see page 3-4.

4. If the selected site contains a single NE, you can click the physical equipment display 
quick-access button to view a graphical representation of the NE.

On the graphical representation of the NE, you can double-click any card to view or 
change information about that card. For more information on using the physical 
equipment display, see page 3-13.

To acknowledge or clear the alarm:

1. Return to the alarm list.

2. With the alarm selected, select Acknowledge Selected Alarms from the Action menu to 
acknowledge the alarm.

Or

Select Clear Selected Alarms from the Action menu to clear the alarm.

When an alarm has been both acknowledged and cleared, it is removed from the Alarm 
List.
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To save or print the alarm listing displayed:

1. Select Export Data from the File menu.

2. Select File or Printer as the destination of the alarm list.

3. Enter a file name to export the alarm list to a file.

Or,

Enter a printer name to send the alarm list to a printer.

4. Click OK.

2.4.3 Using the event list

The event list lists the events that have been reported. The events are color-coded according 
to severity. For more information on using the event list, see page 3-23.

You can customize the events that the event list lists by applying a filter. To apply a filter, select 
Use Filter from the File menu. For information on creating filters, see page 7-4.

To view events for a particular time span:

1. Enter the earliest date and time for which you want to see events in the Start Time text 
box.

Enter the start date and time in the following format: dd/mm/yyyy hh:mm:ss

2. Enter the latest time for which you want to see events in the Stop Time text box.

3. Click Fetch! to fetch events within the specified time span.

To view details about an event:

1. Select the event from the event list.

2. Select Event Detail Display from the Action menu.
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To save or print the event listing displayed:

1. Select Export from the File menu.

2. Select File or Printer as the destination of the event list.

3. Enter a file name to export the event list to a file.

Or,

Enter a printer name to send the event list to a printer.

4. Click OK.

2.5 Monitoring performance

TBD.
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3.1 Overview

You use the fault management function of NetSyncPLUS to monitor the day-to-day operations 
of your NEs. This function is represented by four buttons on the NetSyncPLUS tool bar, which 
enable you to view the following information:

Figure 3.1 illustrates the four buttons on the NetSyncPLUS tool bar that you use to access this 
information.

Figure 3.1 Accessing the fault management function

The following sections provide detailed information about how to use these displays.

map display Provides a map display of your network

physical equipment display Provides details about specific physical NE

alarm list Lists the currently-active alarms

event list List the events that have occurred

map

physical
equipment

alarm
list

event
list
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3.2 Map display 

When you click the map display button on the NetSyncPLUS tool bar, the map display appears 
as shown in Figure 3.2.

Figure 3.2 Map display 

☞ Important. From this display, you can use the Tools menu options or the three quick access 
buttons to access other areas of NetSyncPLUS.

Accesses the Accesses filter 
management

Accesses the physical 

Change the magnification

Provides options to access
all other program functions

Zoom in on the specified area

alarm list equipment display
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3.2.1 Zooming 

You can zoom in on a particular region or site, or you can select an area of the map display 
that you want to zoom in on. 

If a region contains a NE with an alarm, the color of the region changes to indicate the severity 
of the alarm. You can easily view more information about the alarm by zooming in on the 
region and site. To zoom in on a particular region and site:

1. Double-click the region on the map display.

The map display zooms in to display the sites in that region.

2. Click a particular site to select it.

At this point, you can select Show Detail from the File menu to view details about the 
site. For more information, see “Adding, modifying, and deleting sites” on page 3-10.

If the selected site contains a single NE, you can click the physical equipment 
display quick access button to view and modify information about it. For more 
information, see page 3-13,

You can also click the alarm list quick-access buttons to view any alarms at that site. For 
more information, see page 3-16.

To select an area of the map display to zoom in on:

1. Click the magnifying glass icon at the bottom of the map display.

The cursor changes to cross-hairs.

2. Click and drag from one corner of the selection area you to the diagonally-opposite 
corner.

As you drag the cursor, a selection rectangle indicates the selection area. When you 
finish selecting the area, the map display changes to present a closer view of the selected 
area.
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3.2.2 Changing the filter

When you open the map display, it uses a default filter called All that displays all regions and 
all alarms. You can apply a filter that displays only specific regions or sites. 

☞ Important. On the map display, you can only use filters that filter based on regions and sites. 
Filters that use other criteria are not available from the map display. 

To change the filter used:

1. Select Use Filter from the File menu.

The Use Filter dialog box lists the available filters.

2. Select the filter you want to use.

The selection dialog only lists those filters that can be applied to the map display; it lists 
only those filters that filter only on regions and sites. Filters that use other criteria are 
not listed.

Filters are created using the System Administration function. For more 
information on filters, see Chapter 7, System Administration. 
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3.2.3 Adding, modifying, and deleting regions

To add a region:

1. From the Configuration menu, select Region. Then, select Add Region from the cascade 
menu.

The Region Editor dialog box is displayed as shown in Figure 3.3.

Figure 3.3  Region Editor dialog box

2. Enter the latitude and longitude that describe this region’s location.

Typically, you specify a region’s location in general terms (degrees of latitude and 
longitude, but not minutes or seconds).

3. Optionally, specify the level of zooming you want to occur when you double-click on 
the region in the map display.

4. Optionally, double-click each site that you want to include in this region.
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For information on how to add sites, see page 3-10.

5. Select Save from the File menu to save this region.

A dialog box prompts you for a name for this region.

6. Enter a name and click OK.

A message box confirms that the region was added successfully.

To modify an existing region:

1. Optionally, select a region on the map display. 

2. From the Configuration menu, select Region. The, select Modify Region from the 
cascade menu.

If you already selected a region on the map display, the Region Editor dialog box is 
displayed, and you skip the next step.

If you did not already select a region, the Modify Region dialog box is displayed listing 
the available regions.

3. Select the region you want to modify.

4. On the Region Editor dialog box, make any changes to the region.

If a region is marked as moveable, you can change its location either by entering new 
latitude and longitude values on the Region Editor dialog box.

5. Select Save or Save As from the File menu to save the region.

If you select Save, the modified region is saved under the same region name. If you 
selected Save As, a dialog box prompts you for the name of the region.

6. If you selected Save As, enter a name for the region and click OK.
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To delete a region:

1. Optionally, select a region on the map display. 

2. From the Configuration menu, select Region. Then, select Delete Region from the 
cascade menu.

If you already selected a region on the map display, a message box appears asking you 
to confirm the deletion. In this case, skip the next step.

If you did not already select a region, the Delete Region dialog box is displayed listing 
the available regions.

3. Select the region you want to delete.

A message box appears asking you to confirm the deletion.

4. Click OK to delete the region.

☞ Important. When you delete a region, any sites that were assigned to that region are moved 
to UnassignedSites. The NEs assigned to those sites remain assigned. You can then reassign 
the sites (and the NEs they contain) to other regions using the Region Editor dialog box.
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3.2.4 Adding, modifying, and deleting sites

To add a site:

1. From the Configuration menu, select Site. The, select Add Site from the cascade menu.

The Site Details dialog box is displayed as shown in Figure 3.4. 

Figure 3.4 Site Detail dialog box
3-10 NetSyncPLUS User Guide ▲ October 1998



Map display ▲ 3 Fault Management
2. Select the region to which you want to add the site using the Region menu button.

3. Type the name of the new site in the Site Name text box.

4. Enter any other information for this site.

Typically, you specify a site’s location more specifically than the region (not only in 
degrees of latitude and longitude, but also minutes and seconds). 

You can optionally add NEs. 

To add an NE:

1. Click Add.

The Add Network Element dialog box is displayed listing available NEs.

2. Select the NE you want to add to this site.

The NE you selected appears in the Network Elements group box on the Site Details 
dialog box.

To remove an NE from a site:

1. Select the NE you want to remove in the Network Elements group box on the Site 
Details dialog box.

2. Click Remove.

The NE disappears from the Network Elements group box. The NE you removed from 
this site is moved to UnassignedEquipment. You can then reassign the NE to another 
site using the Site Details dialog box.

To save the site: 

1. Select Save or Save As from the File menu.

When you save a new site, a dialog box prompts you for the name of the site.

2. Enter a name for the site and click OK.

A message box confirms that the site was saved successfully.
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To modify an existing site:

1. Optionally, select a site on the map display. 

2. From the Configuration menu, select Site. Then, select Modify Site from the cascade 
menu.

If you already selected a site on the map display, the Site Details dialog box is displayed, 
and you skip the next step.

If you did not already select a site, the Modify Site dialog box is displayed listing sites.

3. Select the site you want to modify.

The Site Details dialog box is displayed.

4. Make any changes to the site.

5. Select Save or Save As from the File menu to save the site.

If you select Save, the modified site is saved under the same site name. If you selected 
Save As, a dialog box prompts you for the name of the site.

6. If you selected Save As, enter a name for the site and click OK.

To delete a site:

1. Optionally, select a site on the map display. 

2. From the Configuration menu, select Site. Then, select Delete Sites from the cascade 
menu.

If you already selected a site on the map display, a message box appears asking you to 
confirm the deletion. In this case, skip the next step.

If you did not already select a site, the Delete Site dialog box is displayed listing the 
available sites.

3. Select the site you want to delete.

A message box appears asking you to confirm the deletion.

4. Click OK to delete the site.

You can also delete a site by selecting Delete from the File menu on the Site Details dialog box.
3-12 NetSyncPLUS User Guide ▲ October 1998



Physical equipment display ▲ 3 Fault Management
☞ Important. When you delete a site, any NEs that were assigned to that site are moved to 
UnassignedEquipment. You can then reassign the NEs to other sites using the Site Details 
dialog box.

3.3 Physical equipment display 

When you click the physical equipment display button on the NetSyncPLUS tool bar, the 
physical equipment display appears. When you initially access this display, it does not show 
any information about the physical NEs. You first need to select the NE for which you want 
to see information.

To view information for a particular NE:

1. Select Open from the File menu.

The Open Equipment dialog box lists the available NEs.

2. Select the NE for which you want to view information.

A graphical representation of the NE is displayed in the physical equipment display as 
shown in Figure 3.5. The exact appearance of this display depends on the type of NE 
you selected.

☞ Important. From this display, you can use the Tools menu options or the three quick 
access buttons to access other areas of NetSyncPLUS.

From this display, you can also use the Configure menu to access the 
configuration dialog boxes for each card in this NE. For more information on 
configuration, see Chapter 4, Configuration Management.
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Figure 3.5 Physical equipment display 

The physical equipment display contains a graphical representation of the LEDs on the 
physical NE that indicate alarms. The color of the LED on the physical equipment 
display indicates the severity of the alarm.

Accesses the configuration Accesses Accesses 
dialog box for the selected
card

the map the alarm list
display
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The physical equipment display does not represent all of the LEDs that the physical 
device has. The LEDs that the physical equipment display represents depend on the 
type of NE.

3. To view information about a particular card, double-click that card in the graphical 
representation.

Or,

Click a status LED to select it. Then, click the configuration quick access button (the 
left-most button at the top of the display).

The configuration dialog box for the card you selected is displayed. For more 
information on configuration, see Chapter 4, Configuration Management.

TSG3800 For all cards except the CPU card, the color of the Fault LED indicates the most 
severe alarm that has occurred on that card. The Power LED is always green.

For the CPU card, the color of the Maj LED indicates the most severe alarm 
that has occurred on any of the cards on this NE. The Power and Run LEDs are 
always green.

PRR10 For the controller and output cards, the color of the Status LED indicates 
the most severe alarm that has occurred on that card. The Power LED is 
green unless a power alarm has occurred.

For the main chassis OSC card, the color of the Crit LED indicates the most 
severe alarm that has occurred on any of the cards on this NE. All other LEDs 
represented on this card are always green.

For the expansion chassis OSC card, all the represented LEDs are always 
green.
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3.4 Alarm list 

When you click the alarm list button on the NetSyncPLUS tool bar, the alarm list appears as 
shown in Figure 3.6. The alarms listed are color coded to indicate severity.

Figure 3.6 Alarm list 

☞ Important. From this display, you can use the Tools menu options or the three quick access 
buttons to access other areas of NetSyncPLUS.

By default, the alarm list is sorted by the alarm time with the latest alarms at the top of the list. 
To sort the alarm list by severity, select Sort from the File menu. Then, select By Severity from 
the cascade menu.

Accesses
 the map 

Accesses filter
management

Accesses the 
physical equipment 
display display
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You can change which alarm attributes the alarm list displays as described on page 3-28. The 
alarm list can contain the following attributes for each alarm:

3.4.1 Changing the filter

When you open the alarm list, it uses a default filter called None, which does not show 
any alarms. To change the filter used:

1. Select Use Filter from the File menu.

The Use Filter dialog box lists the available filters.

2. Select the filter you want to use.

Filters are created using the System Administration function. For more information on 
filters, see Chapter 7, System Administration. 

Attribute Description

Ack Whether the alarm has been acknowledged.

Ack By Logon ID of the operator who acknowledged the alarm

AID Access identifier for the alarm

Alarm Type Type of alarm

Additional Text Any additional text associated with the alarm.

Cleared Whether the alarm has been cleared

Cleared By Logon ID of the operator who cleared the alarm

Cleared Time Time that the alarm was cleared

Description Description of the alarm

Fault Type of condition that caused the alarm

Network Element Network element on which the alarm occurred.

Region Region in which the alarm occurred

Severity Alarm severity

Sequence Number Sequence number for this alarm

Site ID ID of the site in which the alarm occurred

System Affecting Whether this alarm is service affecting

Timestamp Time that the alarm was reported.
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3.4.2 Printing or saving the alarm list

To save or print the alarm listing displayed:

1. Select Export Data from the File menu.

The Export Alarm Data dialog box is displayed as shown in Figure 3.7.

Figure 3.7 Printing or saving the alarm list

2. Select File or Printer as the destination of the alarm list.

3. Enter a file name to export the alarm list to a file.

Or,

Enter a printer name to send the alarm list to a printer.

4. Click OK.
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3.4.3 Configuring the alarm log

By configuring the alarm log, you can specify a filter that determines which alarms are stored 
in the database. To specify the filter to use for the alarm log:

1. Select Alarm Log from the Configure menu.

The Alarm Log dialog box is displayed as shown in Figure 3.8.

Figure 3.8 Alarm Log dialog box

2. To change the filter used to determine which alarms are logged, click Filter.

The Use Filter dialog box lists the available filters.

3. Select the filter you want to use.

Filters are created using the System Administration function. For more information on 
filters, see Chapter 7, System Administration.

4. Click OK on the Alarm Log dialog box to close it.
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3.4.4 Acknowledging and clearing alarms

To acknowledge specific alarms:

1. Select the alarms you want to acknowledge from the alarm list.

Alternatively, you can select Select All Alarms from the Action menu to select all the 
alarms in the alarm list.

2. Select Acknowledge Selected Alarms from the Action menu to acknowledge the alarms 
you have selected.

If the alarm list contains an Ack and/or Ack ID column, those columns are updated for 
the alarms you acknowledged.

To clear specific alarms:

1. Select the alarms you want to clear from the alarm list.

Alternatively, you can select Select All Alarms from the Action menu to select all the 
alarms in the alarm list.

2. Select Clear Selected Alarms from the Action menu to clear the alarms you have 
selected.

If the alarm list contains a Severity column, that column is updated for the alarms you 
cleared.

When an alarm has been both acknowledged and cleared, it is removed from the Alarm List.
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3.4.5 Viewing alarm details

To view detailed information about an alarm:

1. Select the alarm for which you want to view alarm details from the alarm list. Then, 
select Alarm Detail Display from the Action menu.

Or,

Double-click the alarm for which you want to view alarm details.

The Alarm Detail Display dialog box for the selected alarm is displayed as shown 
in Figure 3.9.

Figure 3.9 Alarm Details dialog box

2. When you finish viewing alarm details, select Close from the File menu.
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3.4.6 Communicating directly with an NE

NetSyncPLUS provides a mechanism by which you can enter TL1 command to communicate 
directly with an NE. To do this:

1. Select TL1 from the Tools menu.

The TL1 Session dialog box is displayed as shown in Figure 3.10.

Figure 3.10 TL1 Session dialog box
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2. Select the NE to which you want to send TL1 commands from the Network Element 
drop-down list box.

3. Type any TL1 commands in the text box.

If you need to clear the contents of the text box, click Clear. 

4. When you are finished with the TL1 session, click Close.

3.5 Event list 

When you click the event list button on the NetSyncPLUS tool bar, the event list appears 
as shown in Figure 3.11. Unlike the alarm list (see page 3-16), the event list is a static log; it is 
not updated as new events are generated, and events are not acknowledged or cleared. The 
events listed are color coded to indicate severity. Events that have no color have no severity. 

Figure 3.11 Event list 

Accesses filter
management
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You can change which event attributes the event list displays as described on page 3-28. The 
event list can contain the following attributes for each event:

3.5.1 Changing the filter

When you open the event list, it uses a default filter called None, which does not show 
any events. To change the filter used:

1. Select Use Filter from the File menu.

The Use Filter dialog box lists the available filters.

2. Select the filter you want to use.

Filters are created using the System Administration function. For more information on 
filters, see Chapter 7, System Administration. 

Attribute Description

AID Access identifier for the event

Additional Information Any additional information associated with the event.

Additional Text Any additional text associated with the event.

Description Description of the event

Event Type Type of event

Fault Type of condition that caused the event

Network Element Network element on which the event occurred.

Region Region in which the event occurred

Severity Event severity

Sequence Number Sequence number for this event

Site ID ID of the site in which the event occurred

System Affecting Whether this event is service affecting

Timestamp Time that the event was reported.
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3.5.2 Specifying a time span for the event list

By default, the event list shows all the logged events up to the current time. To view 
events for a particular time span:

1. Enter the earliest date and time (in dd/mm/yyyy hh:mm:ss format) for which you want 
to see events in the Start Time text box.

2. Enter the latest time for which you want to see events in the Stop Time text box.

3. Click Fetch! to fetch events within the specified time span.

3.5.3 Printing or saving the event list

To save or print the event listing displayed:

1. Select Export from the File menu.

The Export Event Data dialog box is displayed as shown in Figure 3.12.

Figure 3.12 Printing or saving the event list

2. Select File or Printer as the destination of the event list.

3. Enter a file name to export the event list to a file.

Or,

Enter a printer name to send the event list to a printer.

4. Click OK.
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3.5.4 Configuring the event log

By configuring the event log, you can specify a filter that determines which events are stored 
in the database. To specify the filter to use for the event log:

1. Select Event Log from the Configure menu.

The Event Log dialog box is displayed as shown in Figure 3.13.

Figure 3.13 Event Log dialog box

2. To change the filter used to determine which events are logged, click Filter.

The Use Filter dialog box lists the available filters.

3. Select the filter you want to use.

Filters are created using the System Administration function. For more information on 
filters, see Chapter 7, System Administration.

4. Click OK on the Event Log dialog box to close it.
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3.5.5 Viewing event details

To view detailed information about an event:

1. Select the event for which you want to view event details from the event list. Then, 
select Event Detail Display from the Action menu.

Or,

Double-click the event for which you want to view event details.

The Event Detail Display dialog box for the selected event is displayed as shown 
in Figure 3.9.

Figure 3.14 Event Details dialog box

2. When you finish viewing event details, select Close from the File menu.
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3.6 Changing the format of the alarm or event list

You can easily customize the alarm and event lists to show the attributes you need to see in 
the most convenient order. 

To add a column for an attribute to the format:

1. From the alarm or event list, select Add Column from the Configure menu.

The Add Column dialog box is displayed as shown in Figure 3.15.

Figure 3.15 Add Column dialog box

2. Select the attribute for which you want to add a column to the format using the Add 
Column menu button.

3. Select the column after which you want to add the new column using the After Column 
menu button and click OK.

The alarm or event list is updated to include the column you added.

4. To save the new format, select Save Layout from the File menu.
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To delete a column from the format:

1. Select Delete Column from the Configure menu.

The Delete Column dialog box is displayed as shown in Figure 3.16.

Figure 3.16 Delete Column dialog box

2. Select the column you want to delete from the format using the Delete Column 
menu button and click OK.

The alarm or event list is updated to exclude the column you deleted.

3. To save the new format, select Save Layout from the File menu.
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To change the order of the columns in the format:

1. Select Move Column from the Configure menu.

The Move Column dialog box is displayed as shown in Figure 3.17.

Figure 3.17 Move Column dialog box

2. Select the column you want to move from the Move Column menu button.

3. Select the column after which you want to place the column from the After 
Column menu button and click OK.

The alarm or event list is updated to reflect the new column order.

4. To save the new format, select Save Layout from the File menu.;
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4 Configuration Management

This chapter describes how to use the configuration management function of NetSyncPLUS.

4.1 Overview 4-3

4.2 Software management 4-4

4.2.1 Loading firmware into NetSyncPLUS 4-5

4.2.2 Deleting firmware from NetSyncPLUS 4-6

4.2.3 Downloading firmware to the equipment 4-7

4.3 Configuration management 4-8

4.3.1 Adding an NE 4-9

4.3.2 Modifying an NE 4-11

4.3.3 Deleting an NE 4-14

4.4 Inventory list 4-15
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4.1 Overview

The configuration management function of NetSyncPLUS is represented by three 
buttons on the NetSyncPLUS tool bar, which enable you to perform the following tasks:

Figure 4.1 illustrates the four buttons on the NetSyncPLUS tool bar that you use to perform 
these tasks:

Figure 4.1 Accessing the configuration management function

The following sections provide detailed information about how to use these displays.

software management Download firmware to the equipment on your network.

configuration 
management

Add, modify, or delete NEs in your network, and enter 
configuration and inventory information about the cards in an NE.

inventory list Export inventory reports about the NEs in your network to a file or 
printer.

software
management

configuration
management

inventory
list
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4.2 Software management

You can use the software management function to download firmware to equipment in 
your network. To download software, you need to:

1. Load the firmware into NetSyncPLUS.

2. Download the firmware from NetSyncPLUS to the equipment.

NetSyncPLUS can store up to ten firmware packages, which you can then download as 
needed. If any previously-loaded package becomes obsolete or unneeded, you can 
easily delete it from NetSyncPLUS.

When you click the Software Management button on the NetSyncPLUS tool bar, the 
Software Management tool bar is displayed as shown in Figure 4.2.

Figure 4.2 Software Management tool bar

The following table describes each of these buttons on this tool bar:

Each of these buttons is described in detail in the following sections.

Load Click this button to load firmware into NetSyncPLUS.

Delete Click this button to delete previously-loaded firmware from NetSyncPLUS.

Download Click this button to download firmware from NetSyncPLUS to the equipment.
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4.2.1 Loading firmware into NetSyncPLUS

You can easily load firmware into NetSyncPLUS and then download it whenever you 
need it. To load firmware:

1. Click Load on the Software Management tool bar.

The dialog box shown in Figure 4.3 prompts you for the location of the firmware to 
load.

Figure 4.3 Loading firmware

2. Enter the directory and filename for the firmware package, and click Accept.

The firmware is loaded into NetSyncPLUS.

3. When the firmware finishes loading, click OK.

You return to the File Selection dialog box so that you can select another firmware 
package to load.

4. When you are finished loading firmware, click Cancel to close this dialog box.
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4.2.2 Deleting firmware from NetSyncPLUS

NetSyncPLUS can store up to ten firmware packages at one time. Different versions of 
the same firmware package are counted as separate packages. For this reason, you may 
need to delete unneeded firmware packages in order to load new ones. To delete a 
firmware package from NetSyncPLUS:

1. Click Delete on the Software Management tool bar.

The dialog box shown in Figure 4.4 lists the name and version for all firmware packages 
currently loaded into NetSyncPLUS.

Figure 4.4 Deleting firmware

2. Select the firmware package you want to delete, and click OK.
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4.2.3 Downloading firmware to the equipment

Once you have loaded firmware into NetSyncPLUS as described on page 4-5, you can 
download it to the equipment. To download the firmware:

1. Click Download on the Software Management tool bar.

The dialog box shown in prompts for the device to which you want to download 
and the firmware package you want to download.

Figure 4.5 Downloading firmware

2. Select the network element to which you want to download the firmware 
package.

3. Select the name and version number of the firmware package you want to 
download, and click OK.

A dialog box confirms that the firmware is being downloaded and indicates when the 
download process finishes.
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4.3 Configuration management

You use the configuration management function to add, modify, or delete NEs on your 
network. When you click the Configuration Management button on the NetSyncPLUS 
tool bar, the Configuration Management tool bar is displayed as shown in Figure 4.6.

Figure 4.6 Configuration Management tool bar

The following table describes each of these buttons on this tool bar:

Each of these buttons is described in detail in the following sections.

Add Click this button to add an NE to your network.

Modify Click this button to modify information about an NE in your network or to enter 
configuration or inventory information for the cards in the NE.

Delete Click this button to delete an NE from your network.
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4.3.1 Adding an NE

To add an NE:

1. Click Add from the Configuration Management tool bar.

The Add Network Element dialog box shown in Figure 4.7 is displayed:

Figure 4.7 Add Network Element dialog box

2. Enter the information for the NE you want to add in the fields on this dialog box and 
click OK.
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The following table describes each field in the Add Network Element dialog box.

After you enter this information and click OK, a message box confirms that the 
NE was successfully created and added to the network.

Field Description

Site The site to which this NE is associated. This drop-down list box lists all 
the sites that are available for your network. To add a site to your 
network, see page 3-10.

Type The type of NE you want to add. This menu button lists three types of DATUM 
NEs.

Name Enter the name assigned to the NE you want to add. 

When a network element is initially installed, it has a factory-assigned 
name, which is the same for all NEs of a particular NE type. You can 
assign a unique, descriptive name to an NE, either directly using the 
craftperson interface for the device or using NetSyncPLUS. Since you 
use the NE’s name to select it in NetSyncPLUS dialog boxes, you want 
to be sure to assign a descriptive name to the NE.

Host Name Enter the network address of the NE’s terminal server. Equivalent to IP 
address.

Service Name Enter the port number used by the NE’s terminal server. Equivalent to port 
number.

Comm Type Select the type of network communication the NE uses. At present, the only 
available communication type is TCP/IP.
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4.3.2 Modifying an NE

You use this option to enter information about each card in the NE, assign a descriptive name 
to the NE, or change the information entered when the NE was added to the network.

To modify an NE:

1. Click Modify on the Configuration Management tool bar.

The Modify Equipment dialog box is displayed listing available NEs.

2. Select the NE you want to modify.

The Modify Network Element dialog box shown in Figure 4.8 is displayed. 

Figure 4.8 Modify Network Element dialog box
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This dialog box contains buttons that you can use to enter information about each of the 
cards in the NE you selected. The buttons that appear on this dialog box depend on the 
type of NE you selected to modify.

In most cases, the name of the button indicates the card to which it applies. 
However, the Routing Information button allows you to change the information 
entered when the NE was added to the network.

3. Click a button to enter or change the associated configuration or inventory 
control information.

A dialog box similar to the example in Figure 4.9 is displayed. The appearance of this 
dialog box depends on the button you clicked on the Modify Network Element dialog 
box.
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Figure 4.9 Input Configuration dialog box

In some cases, the configuration information fields take up the entire dialog box. 
In this case, you select Inventory from the File menu to access a dialog box to 
enter inventory information.

In addition, some configuration dialog boxes have an Edit menu. Using this 
menu, you can access more dialog boxes where you can enter information related 
to this card, such as the ports available on an input card or the thresholds for each 
port.
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4. When you have finished entering information on a configuration dialog box, 
select Save from the File menu to save the information.

To close the dialog box without saving the modified information, select Exit from 
the File menu.

5. When you finish entering or modifying information for the NE, click OK to close 
the Modify Network Element dialog box.

4.3.3 Deleting an NE

To delete an NE from the network:

1. Click Delete from the Configuration Management tool bar.

The Delete Equipment dialog box is displayed listing available NEs. 

2. Select the NE you want to delete.

A dialog box appears asking you to confirm that you want to delete the NE.

3. Click OK to delete the NE.

A message box confirms that the NE was successfully deleted.
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4.4 Inventory list

Using the inventory list function, you can export information about any NE on your 
network to a file or printer. To export this information:

1. Click inventory list on the Configuration Management tool bar.

The dialog box shown in Figure 4.10 appears.

Figure 4.10 Exporting inventory information

2. Select the NE for which you want to print inventory information.

3. Select File or Printer as the destination of the inventory report.

4. Enter a file name to export the report to a file.

Or,

Enter a printer name to send the report to a printer.

5. Click OK.
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5 Performance Management

This chapter describes how to use the performance management function to create 
performance graphs.

5.1 Overview 5-3

5.2 Creating a graph 5-4

5.3 Zooming 5-9
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5.1 Overview

You use the performance management function to create graphs that track the 
performance of the NEs in your network. You can create phase, MTIE, and TDEV 
graphs of your TSG3800 network elements.

To access the performance management function, click Performance Management on 
the NetSyncPLUS tool bar, shown in Figure 5.1.

Figure 5.1 Accessing the performance management function

When you click the performance management button on the NetSyncPLUS tool bar, the 
Graph Selection dialog box shown in Figure 5.2 is displayed.

Figure 5.2 Graph selection

performance
management
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5.2 Creating a graph

To create a performance management graph:

1. Select the type of graph you want to create on the Graph Selection dialog box.

A dialog box similar to Figure 5.3 is displayed. You use this dialog box to select the 
options for the graph you want to create.

Figure 5.3 Graphing options

The options on this dialog box depend on the type of graph you chose. In all cases, 
however, this dialog box contains the following group boxes:

• equipment to graph

• time period for the graph

• a chart list that indicates the color coding that will be used on the graph

2. Select a piece of equipment to add to the graph using the menu buttons in the 
top-left group box (equipment to graph).

3. If you are creating an MTIE or TDEV graph, select the masks you want to use for the 
chart.

4. Specify the time period for the chart.

equipment
to graph

time period
to graph

color coding for the graph
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5. Click Add.

When you select a piece of equipment and add it to the graph, the chart list changes to 
indicate what color will be used to graph that equipment’s performance. For the phase 
graph, each piece of equipment you select results in two entries in the chart list, one for 
each reference clock, as shown in Figure 5.4 .

Figure 5.4 Creating a phase graph

For MTIE and TDEV graphs, each piece of equipment you select results in one entry in 
the chart list as shown in Figure 5.5.

Figure 5.5 Creating an MTIE graph
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If you selected a piece of equipment for which no performance data is available, an 
error message is displayed.

If you need to remove a piece of equipment from the graph, you can select it’s 
entry from the chart list and click Delete.

6. Repeat steps 2 through 5 to add any other pieces of equipment that you want to include 
on this graph.

7. Specify the time period that this graph should reflect using the text boxes in the 
lower-left group box (time period to graph).

8. When you finish adding equipment, click OK to create the graph.

The graph is displayed. Figure 5.6 illustrates a phase graph.

Figure 5.6 Example phase graph

Change the

Zoom in on the 
specified area

magnification
Select a previously-
used zoom level
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Figure 5.7 illustrates an MTIE graph.

Figure 5.7 Example MTIE graph

Change the
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specified area

magnification
Select a previously-
used zoom level

Switch between MTIE and TDEV graphs
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Figure 5.8 illustrates a TDEV graph.

Figure 5.8 Example TDEV graph

9. When you have finished viewing the graph, select Exit from the File menu to return to 
the graphing options dialog box.

Or,

Select another type of graph from the Graph menu to begin creating that type of graph.

Change the

Zoom in on the 
specified area

magnification
Select a previously-
used zoom level
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5.3 Zooming 

You can zoom in on a particular area of the graph to view it more closely. In addition, you can 
select a previously-used zoom level to view that level of detail again. To select an area of the 
graph to zoom in on:

1. Click the magnifying glass icon at the top of the graph display.

The cursor changes to cross-hairs.

2. Click and drag from one corner of the selection area you to the diagonally-opposite 
corner.

As you drag the cursor, a selection rectangle indicates the selection area. When you 
finish selecting the area, the display changes to present a closer view of the selected 
area.

To select a previously-used zoom level:

1. Click the zoom level list icon.

A dialog box appears from which you can select a zoom level.

2. Select one of the zoom levels, and click OK.
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6 Security Management

This chapter describes how to use the security management function to manage users to 
NetSyncPLUS.

6.1 Overview 6-3

6.2 Adding a user 6-4

6.3 Modifying a user 6-5

6.4 Deleting a user 6-5
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6.1 Overview

You use the security management function to add, modify, or delete users of 
NetSyncPLUS. To access the security management function, click Security Management 
on the NetSyncPLUS tool bar, shown in Figure 6.1.

Figure 6.1 Accessing the security management function

When you click the security management button on the NetSyncPLUS tool bar, the 
Security Manager dialog box is displayed as shown in Figure 6.2.

Figure 6.2 Security Manager dialog box

security
management
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NetSyncPLUS provides the following security levels:

6.2 Adding a user

To add a user:

1. Select Add User from the Edit menu.

The Security Editor dialog box shown in Figure 6.3 is displayed:

Figure 6.3 Security Editor dialog box

2. Enter a user ID and password for the user you want to add.

3. Select a security level for this user ID and click OK.

After you enter this information and click OK, a message box confirms that the user was 
successfully added.

User Has view-only access to the network management operations.

Technician Has both view and change access to the network management operations.

Administrator Has both view and change access to all system functions including operations for 
administrating NetSyncPLUS.
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6.3 Modifying a user

To modify the password or security level for a user:

1. Select the user you want to modify from the Security Manager dialog box.

2. Select Modify User from the Edit menu.

The Security Editor dialog box displays the current information about the user as 
shown in Figure 6.4.

Figure 6.4 Security Editor dialog box with user information

3. Change the password and/or security level and click OK.

A message box confirms that the user was successfully modified.
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6.4 Deleting a user

☞ Important. The administrator cannot delete the administrator user ID.

To delete a user:

1. Select the user you want to delete from the Security Manager dialog box.

2. Select Delete User from the Edit menu.

A dialog box appears asking you to confirm that you want to delete the user.

3. Click OK to delete the user.

A message box confirms that the user was successfully deleted.
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This chapter describes how to use the system administration function of NetSyncPLUS to 
construct CMISE filters.

7.1 Overview 7-3

7.2 Constructing a filter 7-4

7.3 Modifying an existing filter 7-6

7.4 Deleting a filter 7-7
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7.1 Overview

You use the system administration function to construct CMISE filters. NetSyncPLUS 
uses filters to determine what information is displayed on the map display, the alarm 
list, and the event list. For example, you can create a filter that only displays alarms 
from specific sites. 

☞ Important. On the map display, you can only use filters that filter based on regions and sites. 
Filters that use other criteria are not available from the map display. For the alarm list, alarm 
log, event list, and event log, you can use any filter.

A CMISE filter is comprised of one or more filter expressions, each of which has the form: 

attributeID operator value

An example filter expression might be:

Region = REGIONONE

A filter expression may consist of one or more simpler filter expressions connected by logical 
operators and optionally grouped by parenthesis. For example:

(( Region = REGIONONE ) AND
NOT (Severity = Warning))

In addition, a filter can contain nested filter expressions as shown in the following example:

((( Region = REGIONONE ) AND
NOT ((Severity = Warning) OR
(Severity = Minor)))

After you have constructed a filter, you can apply it to the map display, alarm list, or 
event list to view only the information that passes the filter. The example filter shown 
above would list only those alarms or events that occurred in REGIONONE and were 
not of Warning or Minor severity. For more information on applying a filter, see page 3-6, page 
3-17, or page 3-24.

To access the system administration function, click System Administration on the 
NetSyncPLUS tool bar, shown in Figure 7.1.
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Figure 7.1 Accessing the system administration function

7.2 Constructing a filter

When you click System Administration on the NetSyncPLUS tool bar, the Alarm Filter 
Manager dialog box is displayed as shown in Figure 7.2.

Figure 7.2 Alarm Filter Manager dialog box

system
administration
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You use the buttons and drop-down list boxes in this dialog box to construct filter expressions 
one at a time. You can also add additional rows (lines) to the filter and parenthesis to group 
filter expressions. In this way, you can build up complex filters.

The following table describes the elements of this dialog box that you use to construct a 
CMISE filter:

☞ Important. NetSyncPLUS reads in the current values for network, sites, and regions 
when you access the system management function. If you make changes to this 
information while you have the Alarm Filter Management dialog box open, you 
request that NetSyncPLUS re-read the information by selecting Refresh Options from 
the File menu.

Element Description

Not Click this check box to insert a logical NOT before the current filter expression.

Attribute Select the attribute that you want to use for the current filter expression.

Relational 
Operator

Select a relational operator that you want to use between the attribute and value 
in this filter expression.

Value Select the value that you want to use for the current filter expression.

Add ( Select this button to add an open parenthesis before the current filter expression.

Add ) Select this button to add a close parenthesis after the current filter expression.

Del ( Select this button to delete an open parenthesis from before the current filter 
expression.

Del ) Select this button to delete a close parenthesis from after the current filter 
expression.

Add Row Select this button to add a row (line). You can add a row either above or below the 
selected row. When you select this button, the current filter expression is copied to 
the new row. You can also select Add Row from the Edit menu to add a row.

Delete Row Select this button to delete the current row (line). You can also select Delete Row 
from the Edit menu to delete the current row.

Logical Select a logical operator from this drop-down list box to add that operator to the 
end of the current line. In this way, you can add logical operators between filter 
expressions.
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To construct a filter:

1. Construct the filter expressions for your filter using the buttons and drop-down list 
boxes on the Alarm Filter Manager dialog box.

To add a row (line) to the filter, including the first line, click Add Row. When you 
add the first row, NetSyncPLUS simply adds the row to the text box in the lower 
half of the dialog box using the currently-selected filter options. When you add a 
new row to a filter that already contains rows, NetSyncPLUS asks whether the new 
row should go before or after the selected row.

To change a row, select it and then select other filter options.

2. When you have finished constructing the filter, select Verify Filter from the Edit 
menu.

A message box appears confirming that the filter is valid or indicating an error.

3. When you have corrected any errors in the filter, select Save or Save As from the 
File menu to save the filter.

When you save a new filter for the first time or if you selected Save As, a dialog box 
prompts you for the name of the new filter.

4. Enter a name for the filter and click OK.

The status bar at the bottom of the dialog box indicates that the filter was successfully 
saved.

7.3 Modifying an existing filter

To open and modify an existing filter:

1. Select Open from the File menu on the Alarm Filter Manager dialog box.

The Open Filter dialog box lists the currently defined filters.

2. Select the filter you want to modify.

The filter you selected is displayed in the Alarm Filter Management dialog box.

3. Make any changes to the filter.

4. Select Save to save the filter or Save As to save the modified filter under another name.
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7.4 Deleting a filter

To delete a filter:

1. Select Delete from the File menu.

The Delete Filter dialog box lists the available filters.

2. Select the filter you want to delete.

A dialog box appears asking you to confirm that you want to delete the filter.

3. Click OK to delete the filter.

The status bar at the bottom of the dialog box indicates that the filter was deleted.
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A Backups and Restores

This appendix describes how to back up and restore the data about your network 
stored in NetSyncPLUS.

A.1 Overview A-3

A.2 Performing a backup A-4

A.2.1 Performing an interactive backup A-4

A.2.2 Performing a scheduled backup A-6

A.3 Performing a restore A-8

A.3.1 Booting from the operating system CD-ROM A-8

A.3.2 Restoring everything A-9

A.3.3 Restoring the file system A-11

A.3.4 Restoring the databases A-11

A.3.5 Restoring the NetSyncPLUS application binaries and data A-13
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A.1 Overview

This appendix describes how to back up the information about your network that is stored in 
NetSyncPLUS and how to restore that information in case of data loss. 

There are several types of backups that you can perform depending on the type of data you 
want to save. You can perform these backups interactively or you can schedule them to 
complete at a specific time.

• Backup of everything

This backup type creates an image of the entire system with virtually every file 
including the operating system, the NetSyncPLUS application and databases. This 
backup type can take from 45 minutes to several hours, depending on how much data 
is on your system.

At a minumum, it is recommended that you perform a back up everything at least once 
each month. Perform this backup when there is little or no activity on the system. For 
example, you might perform this backup on the first Sunday evening of each month.

• Backup of the file system

This backup type creates an image of all file systems including the operating system, 
and the NetSyncPLUS application binaries and data. It does not save the NetSyncPLUS 
databases. It can take from 45 minutes to several hours, depending on how much data 
is on your system.

You can perform this backup if you cannot find a convenient time to back up 
everything. However, since it does not back up the NetSyncPLUS databases, you should 
back them up soon after this backup (within a couple of days).

• Backup of the NetSyncPLUS databases

This backup type creates an image of the NetSyncPLUS databases. It does not save the 
operating system or the NetSyncPLUS application binaries. 

You should perform this backup whenever there is a significant change in the 
configuration of your network devices. Perform this backup when there is little or no 
activity on the system.

If you have not backed up everything during the month (you backed up only the file 
system), you need to perform this backup to make sure your databases are saved at least 
once each month.
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• Backup of the NetSyncPLUS application binaries and data, excluding the databases

 This backup type creates an image of the NetSyncPLUS application binaries and data. It 
does not save the operating system or the NetSyncPLUS databases. 

At a minumum, you should perform this backup after successfully installing or 
upgrading the NetSyncPLUS program. You can perform this backup if you cannot find 
a convenient time to back up everything or to back up the file system.

If you need to restore from your backups, you can restore everything, the file system, the 
NetSyncPLUS databases, or the NetSyncPLUS application binaries and data (excluding the 
databases).

The following sections describe how to perform backups and restores.

A.2 Performing a backup

NetSyncPLUS includes several backup programs that perform the different types of backups. 
This section describes how to use these programs to perform your backups interactively or to 
schedule a backup to be performed later.

To perform a backup of any type, you need one blank 4mm dat tape. 

A.2.1 Performing an interactive backup

With an interactive backup, you start the backup when you want to perform it and respond 
to the backup program’s prompts.

1. Log into the operating system as root (superuser).

2. Make sure the backup tape is write-enabled (check the read-write tab) and mount it in 
the tape drive.

3. Change to the NetSyncPLUS installation directory by typing the following command:

cd /ems/CurrentVersion/bin

4. Start the backup program for the type of backup you want to perform.

To back up everything, type the following command at the prompt:
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./backup.everything

To back up the file system, type the following command at the prompt:

./backup.system

To back up the NetSyncPLUS databases, type the following command at the prompt:

./backup.databases

To back up the NetSyncPLUS application binaries and data, excluding the databases, 
type the following command at the prompt:

./backup.ems

The backup program begins. Follow the backup program’s prompts to perform the 
backup.

If you are backing up everything or backing up the NetSyncPLUS databases, the 
following prompt appears when the database backup begins:

Please mount tape 1 on /dev/rmt/0 and press Return to continue...

This prompt appear regardless of whether the tape is already mounted. Since you have 
already mounted the tape, just press Return.

5. Remove the tape from the tape drive, set the read-write tab to read-only, label the tape 
with the date and backup type, and store the tape in a safe place.
NetSyncPLUS User Guide ▲ October 1998 A-5



Performing a backup ▲ A Backups and Restores
A.2.2 Performing a scheduled backup

With a scheduled backup, you specify the type of backup you want to perform and when to 
perform it. The backup program for a scheduled backup does not prompt for any information. 
It simply performs the backup based on the arguments you provided on the command line 
when you scheduled the backup.

You can only schedule one backup at a time. If you try to schedule a new backup before a 
previously scheduled backup completes, the new backup schedule will overwrite the 
previous backup schedule.

☞ Important. When performing a scheduled backup, you need to make sure that a 
write-enabled backup tape is mounted in the tape drive before the backup begins.

To schedule the backup:

1. Log into the operating system as root (superuser).

2. Change to the NetSyncPLUS installation directory by typing the following command:

cd /ems/CurrentVersion/bin

3. Start the scheduled backup program by typing the following command at the prompt:

./schedule.backup -type everything | database | ems
[ [-date MM/DD -time HH:MM] | [-weekly dayofweek -time HH:MM] | 
[-daily -time HH:MM] ]
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The following table describes these command line options:

For example, to schedule a backup of everything to be performed weekly on Sunday at 
11:00 pm, you would enter:

schedule.backup -type everything -weekly Sun -time 23:00

To schedule a backup of the NetSyncPLUS databases at 1:00 am each day, you would 
enter:

schedule.backup -type database -daily -time 1:00

To schedule a backup of the NetSyncPLUS application binaries and data, excluding the 
databases, to be performed on 5/23 at 11:00 pm, you would enter:

schedule.backup -type ems -date 5/23 -time 23:00

If you specify only the -type option, the specified type of backup will be scheduled 
immediately. 

You can also get help on the schedule.backup program by typing the following 
command:

./schedule.backup -help

-type Specifies the type of backup to perform. Possible backup types are:

• everything: backs up everything.

• database: backs up the NetSyncPLUS databases.

• ems: backs up the NetSyncPLUS application binaries and data, excluding 
the databases.

-date Specifies the date on which you want the backup performed. Specify the 
date using two digits each for the month and year (MM/YY).

-time Specifies the time that you want the backup performed. Specify the time 
using two digits each for the hour and minutes (HH/MM) using a 24-hour 
clock.

-weekly Specifies that the backup should be performed weekly on the specified day 
of the week.

-daily Specifies that the backup should be performed daily.
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A.3 Performing a restore

You can restore any of the information that you have backed up: everything, the file system, 
the NetSyncPLUS databases, or the NetSyncPLUS application binaries and data (excluding the 
databases). You can only restore interactively.

If you are restoring everything or the file system, you need to boot your system from the 
Solaris operating system CD-ROM. The operating system version of the CD-ROM you use to 
boot the system must match your systems current operating system version.

This section describes how to boot your system from the operating system CD-ROM and how 
to restore your data.

A.3.1 Booting from the operating system CD-ROM

You only need to boot your system from the Solaris operating system CD-ROM if you are 
restoring everything or the file system. For other types of restores, you can skip this section.

To boot from the operating system CD-ROM:

1. Mount the Solaris operating system CD-ROM in the CD-ROM drive.

The operating system version of the CD-ROM you use to boot the system must match 
your system’s current operating system version.

2. Halt your system by typing STOP+A. 

The command monitor prompt (OK) is displayed.

3. Type the following command to boot from the operating system CD-ROM:

boot cdrom - s

The system boots from the CD-ROM into mini-root. It may take a few minutes for the 
prompt (#) to appear.
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A.3.2 Restoring everything

To restore everything, you need the most recent backup tape on which you backed up 
everything. Then, you need to boot the system from the operating system CD-ROM as 
described above.

To restore everything, you first restore the file system. Then, you restore the NetSyncPLUS 
databases. Both of these procedures are described below.

To restore the file system:

1. Insert the backup tape in the tape drive.

2. Type the following commands at the mini-root prompt (#):

cd /tmp
TAPE=/dev/rmt/0n
export TAPE
mt rewind
tar xv

At this point, you are ready to start the restore program.

3. To start the restore program, type the following command at the mini-root prompt (#):

./restore.system

4. Follow the restore program prompts to restore the file system.

When the file system restore completes, a prompt appears letting you know that the 
system is about to reboot.

5. Press any key to reboot.

When the system reboots, it ejects the tape.

To restore the databases:

1. Reinsert the tape into the tape drive.

2. Log in a root (superuser).

3. Change to the NetSyncPLUS installation directory by typing the following command:

cd /ems/CurrentVersion/bin
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4. Type the following command:

./restore.databases

5. Follow the restore program prompts to restore the databases.

The following lists the responses you should provide to those prompts for which the 
proper answer may not be obvious:

• When the database restore begins, the following prompt appears:

Please mount tape 1 on /dev/rmt/0 and press Return to 
continue...

This prompt appear regardless of whether the tape is already mounted. Since you 
have already mounted the tape, just press Return.

• Answer n when the following restore program prompt appears:

Do you want to back up the logs? (y/n)

• Answer n when the following prompt appears:

Restore a level 1 archive (y/n)

• Answer n when the following prompt appears:

Do you want to restore log tapes? (y/n)

When the database restoration completes, a prompt appears asking you if you want to 
reboot the system.

6. Type Y to reboot.

Your system reboots.
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A.3.3 Restoring the file system

To restore the file system, you need the most recent backup tape on which you backed up the 
file system or on which you backed up everything. Then, you need to boot the system from 
the operating system CD-ROM as described on page A-8.

To restore the file system:

1. Insert the backup tape in the tape drive.

2. Type the following commands at the mini-root prompt (#):

cd /tmp
TAPE=/dev/rmt/0n
export TAPE
mt rewind
tar xv

At this point, you are ready to start the restore program.

3. To start the restore program, type the following command at the mini-root prompt (#):

./restore.system

4. Follow the restore program prompts to restore the file system.

A.3.4 Restoring the databases

To restore the databases, you need the most recent backup tape on which you backed up the 
databases or on which you backed up everything.

To restore the databases:

1. Insert the backup tape in the tape drive.

2. Log into the system as root (superuser). 

3. Change to the NetSyncPLUS installation directory by typing the following command:

cd /ems/CurrentVersion/bin

4. Type the following command:
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./restore.databases

5. Follow the restore program prompts to restore the databases.

The following lists the responses you should provide to those prompts for which the 
proper answer may not be obvious:

• When the database restore begins, the following prompt appears:

Please mount tape 1 on /dev/rmt/0 and press Return to 
continue...

This prompt appear regardless of whether the tape is already mounted. Since you 
have already mounted the tape, just press Return.

• Answer n when the following restore program prompt appears:

Do you want to back up the logs? (y/n)

• Answer n when the following prompt appears:

Restore a level 1 archive (y/n)

• Answer n when the following prompt appears:

Do you want to restore log tapes? (y/n)

When the database restoration completes, a prompt appears asking you if you want to 
reboot the system.

6. Type Y to reboot.
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A.3.5 Restoring the NetSyncPLUS application binaries and data 

To restore the NetSyncPLUS application binaries and data (excluding the databases), you need 
the most recent backup tape on which you backed up this information.

To perform the restore:

1. Insert the backup tape in the tape drive.

2. Log into the system as root (superuser). 

3. Change to the NetSyncPLUS installation directory by typing the following command:

cd /ems/CurrentVersion/bin

4. Type the following command:

./restore.ems

5. Follow the restore program prompts to restore the application binaries and data.
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